User’s Guide to COSI-CORR
Co-registration of Optically Sensed Images and Correlation

François Ayoub, Sébastien Leprince, and Jean-Philippe Avouac

California Institute of Technology
1200 East California Blvd, Pasadena, CA 91125, USA

June 9, 2017

Abstract

This document is a user’s guide for the installation and the use of COSI-Corr. COSI-Corr is a software module integrated in ENVI, which provides tools to accurately orthorectify, co-register, and correlate optical remotely sensed images (frame and pushbroom satellite images) with the ultimate objective of retrieving ground surface deformation from multi-temporal images. Although this module is tailored to measure ground deformations such as coseismic deformation, glacier flows, sand dune migrations, slow landslides, etc, it can also be a valuable tool for many other change detection applications requiring accurate coregistration of images. A sub-pixel detection capability is expected, depending on the quality and the noise level of the data.
Contents

1 Preface .......................................................... 6
   1.1 About This Document ................................................. 6
   1.2 Who Will Use This Document ......................................... 6
   1.3 About COSI-Corr .................................................. 6
   1.4 Support .......................................................... 6
   1.5 Citation ........................................................ 6
   1.6 Disclaimer ......................................................... 7

2 Installation and Getting Help ........................................ 8
   2.1 How to get COSI-Corr ............................................... 8
   2.2 Requirements ...................................................... 8
   2.3 Installation ....................................................... 9
   2.4 Getting Help ...................................................... 12

3 Introduction: A Typical Processing Chain ................................ 13

4 Aerial Imagery Specific ................................................. 13
   4.1 Interior Orientation ................................................. 14
   4.2 Exterior Orientation ............................................... 16

5 Satellite Imagery Specific ............................................. 16
   5.1 Ancillary File ..................................................... 16
   5.2 Satellite specifics .................................................. 16

6 Mars Imagery Specific .................................................. 17
   6.1 Ancillary File ..................................................... 17
   6.2 HiRISE/CTX general process (pre-COSI-Corr) ..................... 17
   6.3 Notes on HiRISE/CTX specifics ................................... 19

7 Tie Points and GCPS ................................................... 19
   7.1 Tie points Selection ............................................... 19
   7.2 Tie points to GCPS ............................................... 20

8 GCPS Optimization ..................................................... 21
   8.1 Miscellaneous ..................................................... 24

9 Orthorectification and Resampling .................................... 24
   9.1 Orthorectification ................................................ 24

10 Correlation and Displacement Measurements ........................... 26
    10.1 Frequency Correlator .............................................. 27
    10.2 Statistical Correlator .............................................. 28
    10.3 Batch Correlation ................................................ 29
        10.3.1 Batch Correlation input parameters ....................... 29
        10.3.2 Batch Correlation execution ............................... 30

11 Tools ............................................................. 30
    11.1 Non Local Means Filter ......................................... 30
        11.1.1 Filter Process ............................................... 31
        11.1.2 Filter Parameters (Fig. 12) ............................... 32
        11.1.3 Advanced Filter Parameters (Fig. 13) .................... 32
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>11.2 Image Detrending</td>
<td>33</td>
</tr>
<tr>
<td>11.3 Image Warping</td>
<td>35</td>
</tr>
<tr>
<td>11.3.1 Image warping from tie-points</td>
<td>35</td>
</tr>
<tr>
<td>11.3.2 Image warping from correlation</td>
<td>36</td>
</tr>
<tr>
<td>11.4 Discard/Replace Image Values</td>
<td>38</td>
</tr>
<tr>
<td>11.5 Destripe Image</td>
<td>38</td>
</tr>
<tr>
<td>11.5.1 Manual Orientation</td>
<td>39</td>
</tr>
<tr>
<td>11.5.2 Automatic Orientation</td>
<td>40</td>
</tr>
<tr>
<td>11.6 Vector Field</td>
<td>40</td>
</tr>
<tr>
<td>11.7 Stacking Profiles</td>
<td>42</td>
</tr>
<tr>
<td>11.7.1 Orient Fault</td>
<td>42</td>
</tr>
<tr>
<td>11.7.2 Stack</td>
<td>43</td>
</tr>
<tr>
<td>11.8 Manual Stacking Profiles</td>
<td>45</td>
</tr>
<tr>
<td>11.9 Epipolar Projection</td>
<td>47</td>
</tr>
</tbody>
</table>

12 Miscellaneous                              48
List of Figures

1. COSI-Corr into ENVI ......................................................... 12
2. Aerial image fiducial points selection ....................................... 14
3. Interior Orientation Window .................................................. 15
4. Exterior Orientation Window .................................................. 16
5. Tie Points to GCPS Window .................................................. 20
6. GCPS text File Format ......................................................... 21
7. GCPS Optimization Window ................................................... 22
8. Orthoresampling Window ...................................................... 25
9. Correlation Window ............................................................ 26
10. Frequency Correlator Window ................................................ 27
11. Statistic Correlator Window ................................................... 28
12. Non-Local Means Filter ....................................................... 31
13. Non-Local Means Filter Advanced Parameters .......................... 33
14. Image Detrending ............................................................... 34
15. Image Detrending ............................................................... 34
16. Image Detrending ............................................................... 35
17. Image Detrending ............................................................... 36
18. Image Warping ................................................................. 37
19. Image Filter Window .......................................................... 38
20. Destripping Selection Window ............................................... 39
21. Destripping Stacking Window ............................................... 41
22. Destripping Corrected Window ............................................... 42
23. Vector Field Window .......................................................... 43
24. Profile Stacking Window ...................................................... 44
25. Manual Stacking ............................................................... 45
26. Manual stack ................................................................. 46
27. Epipolar Projection ............................................................. 47

List of Tables
1 Preface

1.1 About This Document

Section 1 presents some general information about COSI-Corr. Section 2 presents the COSI-Corr downloading instructions and installation guidelines. Section 3 presents the successive steps necessary to process a pair of images. Sections 4 to 10 detail each function available in COSI-Corr; their chronology reflects more or less the chronology presented in section 3.

1.2 Who Will Use This Document

This documentation is aimed at scientists whose interest is in working with optical remotely sensed images (aerials or satellites). Users are likely to be Earth scientists looking for seismic ground deformations, glacier flows, sand dune displacements, slow landslides, or more generally looking for horizontal changes between multi-temporal images.

Users do not need to have a programming background but will need some familiarities with the concepts and vocabulary of remote sensing. A basic knowledge of the ENVI software will be useful as COSI-Corr is integrated in ENVI.

1.3 About COSI-Corr

The COSI-Corr software has been developed by François Ayoub, Sébastien Leprince, and Jean-Philippe Avouac (PI), and is mainly an implementation of the procedures described in:


The main tasks performed by COSI-Corr are precise orthorectification, images co-registration, and correlation. Although the orthorectification and co-registration are tailored for remotely sensed images, the correlation can be applied to any types of images. Several post-processing utilities are available such as denoising, vector field display, profile stacking tool, and destriping tools, ...

COSI-Corr has been designed to retrieve the sub-pixel displacements between optical images. However, it is necessary to understand that even though images will be used to their full extent, limiting factors such as uncorrected topography, noise, resolution, ... will affect the measurement results.

1.4 Support

COSI-Corr has been developed at the California Institute of Technology (Caltech, supported by the Caltech Tectonics Observatory, the Moore Fundation, and the Keck Institute for Space Studies.

1.5 Citation

The Caltech Tectonics Observatory (TO) is making this module available to you in hopes that the software will enhance your research. A number of individuals have contributed to the development of COSI-Corr. The authors would like to thank Rémi Michel and Renaud Binet for their insightful comments and their early work in the field of sub-pixel image registration and correlation (Van Puymbroeck et al. (2000)). We also thank Sylvain Barbot for his work on the SPOT 5 ancillary data, and David Fanning for some IDL functions.

1.6 Disclaimer

NONEXCLUSIVE, NON-TRANSFERABLE LICENSE AGREEMENT FOR RESEARCH PURPOSES ONLY FOR COSI-Corr Software (Co-registration of Optically Sensed Images and Correlation).

The California Institute of Technology (CIT) will provide you, a not-for-profit institution (LICENSEE), with the Co-registration of Optically Sensed Images and Correlation Software (COSI-Corr). Software is made available to LICENSEE on the following terms:

1. Definitions:
   

   (b) 'Source Code' is defined as code written in human-readable format or in a high-level program language.

   (c) 'Derivative Works' means any work consisting of revisions, annotations, elaborations, or other modifications to Software which, as a whole, represent an original work of authorship. Derivative Works includes any updates and new releases of the Software developed during the term of this license, inclusive of backups, updates, or merged copies permitted hereunder including the file structures, programming instructions, user interfaces and screen formats and sequences.

2. CIT retains ownership of any copyright rights to the Software licensed under this Agreement.

3. CIT agrees to grant LICENSEE a nonexclusive, non-transferable, royalty-free license, under the copyright rights and any applicable patent rights, to use COSI-Corr for internal research purposes only. This license specifically excludes the right to sublicense COSI-Corr in any form, and it also excludes the right to use COSI-Corr for any commercial or for-profit purpose.

4. LICENSEE agrees to grant Caltech a fully paid-up, royalty-free nonexclusive license for educational and research purposes to any Derivative Works of Software that are owned or controlled by Licensee.

5. LICENSEE may incorporate Software with other source code developed by LICENSEE (Incorporated Work) for the sole purpose of using Software for research internal to LICENSEE and not for any other redistribution. LICENSEE may not distribute any Incorporated Work outside of LICENSEE, and specifically LICENSEE may not provide Software or any Incorporated Work under an open source license such as the Gnu Public License (www.gpl.org). If the creation of an Incorporated Work would require LICENSEE to distribute Software under an open source license, then LICENSEE agrees not to make such incorporation.
6. Software is experimental in nature and is being licensed as is. The license of COSI-Corr does not include any technical support or documentation.

7. LICENSEE hereby represents and warrants that it is a not-for-profit entity.

8. CIT represents and warrants that it has the right to license Software.

9. LICENSEE agrees that any person within LICENSEE utilizing Software will be advised of, and is subject to, the conditions in this Agreement.

10. NO WARRANTY: SOFTWARE IS PROVIDED AS-IS WITHOUT WARRANTY OF ANY KIND INCLUDING ANY WARRANTIES OF PERFORMANCE OR MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE OR PURPOSE (AS SET FORTH IN UCC 23212-2313) OR FOR ANY PURPOSE WHATSOEVER, HOWEVER USED. IN NO EVENT SHALL CIT BE LIABLE FOR ANY DAMAGES OR COSTS, INCLUDING BUT NOT LIMITED TO INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND, INCLUDING ECONOMIC DAMAGE OR INJURY TO PROPERTY AND LOST PROFITS, REGARDLESS OF WHETHER CIT SHALL BE ADVISED, HAVE REASON TO KNOW, OR IN FACT SHALL KNOW OF THE POSSIBILITY. LICENSEE BEARS ALL RISK RELATING TO QUALITY AND PERFORMANCE OF SOFTWARE OR ANY DERIVATIVE WORKS THEREOF.

11. All right, title, and interest in and to all data, information, and inventions that result from use of Software by the LICENSEE shall vest in and belong to the LICENSEE.

12. This Agreement is governed by the laws of the State of California, and any action brought hereunder shall be within the state of California.

2 Installation and Getting Help

2.1 How to get COSI-Corr

Users must register through the Caltech Tectonics Observatory web site and accept the licensing agreement to download COSI-Corr (COSI-Corr download\(^1\)). A zipped package containing the COSI-Corr module and the User’s guide should be downloaded and installed (Sec. 2.2, 2.3). All materials obtained are subject to the licensing agreement.

2.2 Requirements

COSI-Corr has been mostly developed in IDL, which is platform independent. However, for efficiency purposes, some COSI-Corr algorithms have been implemented in C/C++ and fortran. These compiled algorithms have been compiled and tested on Windows, Linux and Mac OS systems, but not extensively. Requirements are:

- ENVI 4.7 and up (www.excelisvis.com). ENVI 5 users will need to use “ENVI Classic” which is bundled with ENVI 5.
- 64b Windows, Linux, or Mac OS.
- At least 2Gb RAM.
- Multi-cores processor recommended.

Mars HiRISE/CTX users will also need the following:

\(^1\)http://www.tectonics.caltech.edu/slip_history/spot_coseis/index.html
• ISIS 3.4.3 and up (isis.astrogeology.usgs.gov). Note that ISIS is only available for Linux and Mac OS.

• USGS scripts to transform HiRISE/CTX raw imagery in Socet Set/COSI-Corr compliant format: hi4socet, hinoproj,... The scripts are provided in the COSI-Corr package, but user should seek updated codes from the USGS if needed (planetaryphotogrammetry@usgs.gov).

• HiRISE toolkit from Adam O’Connor (can be loaded from Exelis website), to properly open and read map information of HiRISE images in ENVI. The toolkit is provided in the COSI-Corr package.

2.3 Installation

If you have a previous version of COSI-Corr installed, you need to remove it first.

Let’s assume that you want COSI-Corr to be installed in a folder named mySoftware. For instance:

C:\Users\John McClane\Documents\mySoftware \ \ for Windows
/home/johnMcClane/mySoftware \ \ for Linux
/Users/johnMcClane/Documents/mySoftware \ \ for Mac

You can name and choose the location of this folder as you wish. Copy the cosicorr-lin.tar.gz (Linux) or cosicorr-win.zip (Windows) or cosicorr-mac.tar.gz (Mac) depending on your OS in this folder (mySoftware). Unzip the file. A new folder names cosi-corr will be created in mySoftware directory:

C:\Users\John McClane\Documents\mySoftware\cosi-corr \ \ for Windows
/home/johnMcClane/mySoftware/cosi-corr \ \ for Linux
/Users/johnMcClane/Documents/mySoftware/cosi-corr \ \ for Mac

We’ll refer to this cosi-corr directory full path as pathToCosi for notation simplicity. Each time you see pathToCosi you’ll need to replace it by the full path. The cosi-corr directory contains the following folders: save_add, cosi-modules, and usgs. The folder usgs contains the routines to pre-process Mars imagery (HiRISE and CTX). If you do not plan to work on Mars imagery, the usgs folder can be deleted. Note that the routines use USGS ISIS software which is only available on Linux and Mac.

Follow the 4 steps described above to complete the installation:

1. Copy the ENVI files envi.cfg and e_locate.pro in pathToCosi. These files are found in the ENVI distribution usually in, for example:

C:\Program Files\ITT\IDL71\products\envi47\menu \ \ for Windows
/usr/local/exelis/envi50/classic/menu/ \ \ for Linux
/Applications/exelis/idl82 \ \ for Mac

Edit (using a text editor) the envi.cfg that you copied in pathToCosi and specify the following:

• default save_add directory = pathToCosi/save_add
• total cache size (Mb) = 1000
• image tile size (Mb) = 100

2. Create the two following environment variables: IDL_PATH and IDL_DLM_PATH. See below for OS specifics:

\[2\]Don’t forget here to enter the full path, for instance /home/johnMcClane/mySoftware/cosi-corr/save_add.
\[3\]or more depending on your RAM available, but don’t allocate all of your RAM.
\[4\]Not recommended to go over 150, unless you have a lot of RAM.
**Windows OS** Windows path can be updated from Control Panel → System → Advanced System Settings → Environment Variables. In the System Variables section, click on New, then for the variable name enter:

`IDL_PATH`

and for the variable value enter:

`pathToCosi;<IDL_DEFAULT>`

\ e.g., C:\Users\John McClane\Documents\mySoftware\cosi-corr;<IDL_DEFAULT>

Note that `<IDL_DEFAULT>` must be typed verbatim.

Similarly, create a new environment variable by clicking on New, then for the variable name enter:

`IDL_DLM_PATH`

and for the variable value enter:

`pathToCosi/cosi-modules;<IDL_DEFAULT>`

\ e.g., C:\Users\John McClane\Documents\mySoftware\cosi-corr\cosi-modules;<IDL_DEFAULT>

Alternatively, if you cannot update the environment variables because you don’t have the right to (admin right needed), you can update them using the IDL development environment (IDLDE). Open ENVI+IDL and in the IDL development environment go to Window → Preferences → IDL (click on the arrow next to IDL to display menu) → Paths. Then select IDL path in the scrolling menu and click “insert”. Select the pathToCosi directory. Click on “Move up” to place the new path above the IDL_DEFAULT. Select now DLM path in the scrolling menu and click “insert”. Select the pathToCosi/cosi-modules directory. Click on “Move up” to place the new path above the IDL_DEFAULT.

You need the Visual C++ Redistributable package to be installed on your computer. If it is not already installed from a previous software installation, you can download the package here: http://www.microsoft.com/en-us/download/. In ‘Popular downloads’ select the ‘Developer Tools’ category, and download the ‘Visual C++ Redistributable Packages for Visual Studio’ (click on the blue link) and follow instructions. Reboot your computer.

**Linux OS** You need to update your startup shell script to indicate to the operating system where the necessary COSI-Corr files are. Most Linux distributions use the bash shell by default although several other shell are available (bash, esh, zsh, etc). If you don’t know which is your default shell, you can find out by typing in a terminal the following:

```
ps -p $`
```

Examples on how to update you startup shell script are given for the bash shell. If you are using a different shell, please refer to its documentation to create environment variable.

Edit your .bashrc file using a text editor. The .bashrc file is usually located in your home directory (e.g. /home/johnMcClane/). Warning, the .bashrc is a hidden file, so you may need to activate the “show hidden files” if you are using the GUI interface of Linux. Edit the .bashrc file and add the following at the end of the file:

```
source /usr/local/exelis/envi50/bin/envi_setup.bash
export IDL_PATH='pathToCosi:<IDL_DEFAULT>,'
export IDL_DLM_PATH='pathToCosi/cosi-modules:<IDL_DEFAULT>,'
export PATH=$PATH:pathToCosi/usgs
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:pathToCosi/cosi-modules
```
Note 1: You need to update the full path of the first line of code above
(source /usr/local/exelis/envi50/bin/envi_setup.bash) with the correct path of your system.
Note 2: <IDL_DEFAULT> must be typed verbatim.
Note 3: The single quotes for IDL_PATH and IDL_DLM_PATH are mandatory.

Save the file and close it.

Mac OS Please note that the Mac version of COSI-Corr is new and has only been lightly tested.
You need to update your startup shell script to indicate to the operating system where the
necessary COSI-Corr files are. Most Mac OS X versions use the bash shell by default, although
several other shell are available (bash, csh, zsh, etc). If you don’t know what is your default shell,
you can find out by typing in a terminal the following:

```bash
ps -p $$
```

Examples on how to update you startup shell script are given for the bash shell. If you are using
a different shell, please refer to its documentation to create environment variables.
Edit your .bash_profile file using a text editor. The .bash_profile file is usually located in your
home directory (e.g. /Users/johnMcClane). Warning, the .bash_profile is a hidden file. If the
file does not exist, you need to create it (keep same name (.bash_profile) and home directory).
Edit the .bash_profile file and add the following at the end of the file:

```bash
source /Applications/exelis/envi50/bin/envi_setup.bash
export IDL_PATH='""'
export IDL_DLM_PATH='""'
export PATH=$PATH:pathToCosi/usgs
export DYLD_LIBRARY_PATH=$DYLD_LIBRARY_PATH:pathToCosi/cosi-modules
```

Note 1: You need to update the full path of the first line of code above
(source /Applications/exelis/envi50/bin/envi_setup.bash) with the correct path of your system.
Note 2: <IDL_DEFAULT> must be typed verbatim.
Note 3: The single quotes for IDL_PATH and IDL_DLM_PATH are mandatory.

Save the file and close it.

If you are using an ENVI version different than ENVI 4.7, you need to create a symbolic link to
an IDL library:
(a) Locate the relevant idl library: Depending on your ENVI version it will have a different name
and should be something like:

```bash
libidl.8.0.dylib    \   for ENVI 4.8
libidl.8.2.dylib    \   for ENVI 5.0
libidl.8.3.dylib    \   for ENVI 5.1
```

The path to this library is for instance /Applications/exelis/idl82/bin/bin.darwin.x86_64/ for
a standard installation of ENVI 5.0. This path will depends on your own setup.
(b) In a terminal, type5:

```bash
cd pathToCosi/cosi-modules
ln -s path-to-libidl.x.x.dylib libidl.7.1.dylib
```

3. For Mars imagery users only:

5Replace pathToCosi with full path and replace path-to-libidl.x.x.dylib with full path and name of the library identified in
(a).
• USGS Isis-3 software download and installation: See Isis install\(^6\).
  Basic guideline: ISIS installation is a two steps process. First you install the software (binaries). Second you install the "data" which contain all the imagery ancillary information. Beware the data files are very large (>50Gb for MRO mission only). If you plan to use only HiRISE and/or CTX, you just need to download the MRO mission data.

• Edit and update USGS code hi4socet.pl (located in pathToCosi/usgs/) to proper path: In the early lines replace $hinoproj_path = "/usgs/cdev/contrib/bin/" to $hinoproj_path = "pathToCosi/usgs/"\(^7\)

4. Check COSI-Corr installation:

   (a) Launch ENVI. For Windows user, launch ENVI (or ENVI Classic if you have ENVI 5). For Linux and Mac user, start a new terminal and type:

   ```
   envi \ if using ENVI 4.7 or 4.8
   envi -classic \ if using ENVI 5.0 and above
   ```

   Mac users, note that it is not recommended to use the Mac OS GUI to launch ENVI.

   (b) The COSI-Corr menu should appear in the ENVI tool bar (Fig. 1). If it is not, please check that you updated the envi.cfg file correctly and that the IDL_PATH is correct.

   (c) Once the COSI-Corr menu is displayed in the ENVI toolbar, do “Cosi-Corr → About Cosi-Corr”. Information about COSI-Corr should appear. If an error message is displayed instead, please check the IDL_DLM_PATH and the LD_LIBRARY_PATH (for Linux) or DYLD_LIBRARY_PATH (for Mac) are correct.

   It is recommended to register and visit regularly the COSI-Corr forum (http://www.tectonics.caltech.edu/forum/) where you will find tips, bug reports, thematic/technique discussions, and feedbacks from other COSI-Corr users.

   Do not change any file name, folder name, and folder organisation inside pathToCosi. If you are not planning on using Mars imagery, you can delete (but are not obliged) usgs folder and cosi-corr/envi_hirise_toolkit.sav.

   ![Figure 1: Example of the COSI-Corr menu inserted in ENVI between the Basic Tool and Classification top level menus](image)

2.4 Getting Help

To ask for information, help, report a bug or a suggestion, please first browse the COSI-Corr forum (http://www.tectonics.caltech.edu/forum/) as the problem you are facing may have been already reported.


\(^7\)Replace pathToCosi with full path
3 Introduction: A Typical Processing Chain

The driving motivation for implementing COSI-Corr was to set up a tool that retrieves co-seismic ground displacements from pre- and post-earthquake images. Although the description is aimed at seismo-tectonics, it can be applied to any other change detection application. We describe below the successive steps to achieve precise co-registration and derive deformation measurements. We assume here that we have two images bracketing a seismic event. Before correlation, the images must be cleaned from geometric artifacts such as topography, and co-registered precisely:

1. Define the Interior Orientation (aerial) or Ancillary data (satellite) of the two images (Sec. 4.1, 5.1).

2. Orthorectify the pre-earthquake image:
   (a) Construct a Ground Control Points (GCPS) file to refine the pre-earthquake image absolute geolocation and coregistration to the Digital Elevation Model (DEM). GCPS are defined either with GPS campaigns or by taking tie points between the image and a geolocalized reference (orthorectified image, shaded DEM, digitalized high resolution map, ...) (Sec. 7.1). The tie points are then converted into GCPS (Sec. 7.2) using the georeferencing parameters of the reference image and a DEM. Those GCPS can be optimized if necessary (Sec. 8).
   (b) Compute the mapping matrices to transform the raw pre-earthquake image into an orthorectified image and resample it (Sec. 9).

3. Orthorectify the post-earthquake image:
   (a) Select tie points between the post-earthquake image and the orthorectified pre-earthquake image (Sec. 7.1).
   (b) Convert these tie points into GCPS (Sec. 7.2).
   (c) Optimize the GCPS of the post-earthquake image in order to precisely co-register the post-earthquake image to the orthorectified pre-earthquake image (Sec. 8).
   (d) Compute the mapping matrices to transform the raw post-earthquake image into an orthorectified image and resample it (Sec. 9).

4. Correlate the two co-registered and orthorectified images. The result will be a three bands file containing the E/W displacement map (positive toward the East), the N/S displacement map (positive toward the North), and the SNR assessing the quality of the measure (Sec. 10).

4 Aerial Imagery Specific

Film based aerial images must be scanned with a high spatial and radiometric resolution to accurately retrieve the film’s information. A radiometric resolution of at least 8 bits (10-12 recommended), a geometric resolution of 5 to 15 µm (5000 dpi to 1700 dpi), and a stability of around 2-3 µm are desired. Zeiss and Leica, for example, provide suitable aerial images scanners. It is recommended to scan in grayscale (B&W) the negative and not the photo paper print.
4.1 Interior Orientation

The Interior Orientation (IO) of the camera gives a mathematical representation of the camera geometry and distortions. This step is accomplished with the help of the camera calibration report which is normally obtained on demand, and follows the classical photogrammetry techniques (Wolf & Dewitt (2000)).

The “Aerial Imagery → Interior Orientation → Fiducial Points Selection Tool” function allows to select the fiducial points on the image and to enter their measurements, which are read from the calibration report (Fig. 2). Once the points are selected, save the file (“File → Save Points to ASCII”).

Note, in the recent versions of ENVI, the fiducial points selection tool is embedded in the ENVI “Build RPCs” GUI. When opening the “Aerial Imagery → Interior Orientation → Fiducial Points Selection Tool” the “Build RPCs” GUI will open. Click on the “Select Fiducials in Display...” button to access the fiducial selection tool. Once the points are selected, save the file (“File → Save Points to ASCII”), close the “Build RPCs” GUI, and move to the Interior Orientation Setup.

![Figure 2: Fiducial points selection with the help of the calibration report](image)

The “Aerial Imagery → Interior Orientation → Interior Orientation Setup” function generates the Interior Orientation file and gathers the camera information read from the calibration report (Fig. 3):

1. Calibrated focal length, in meters.
2. Principal point offset, in millimeters.
3. Fiducial measures. You can enter the points either manually or by loading the file created with the “Fiducial Points Selection Tool”. The 2D affine transformation between the image reference system and the camera reference system will be automatically computed.
4. Radial lenses distortions correction coefficients. Depending on the data supplied by the calibration report, enter directly the coefficients or compute them from laboratory measurements using the “Radial Measures” button.

5. Tangential lenses distortions correction coefficients. Currently, only the coefficients can be entered if supplied by the calibration report. The correction applied is the one described in Wolf & Dewitt (2000).

6. Atmospheric correction. Check if you want to correct for atmospheric diffraction. The correction assumes a standard atmosphere and follows the adapted method described in Wolf & Dewitt (2000).

Once the parameters are entered, select a name for the IO file to be created, and click OK.

**Note 1:** The radial and tangential lenses distortions, as well as the atmospheric diffraction, have typically an amplitude of around 1 to 4 $\mu$m only. Due to the scanners resolution and stability, consequences will not be dramatic if they are not accounted for.

**Note 2:** If the calibration report is not available, the IO can still be built but the lenses distortions, principal point offset, and fiducial points measures will not be accounted for. The focal length, the scanning
resolution and the fiducial points coordinates (in pixel) are needed. The principal point is assumed to be at the crossing of the lines joining the opposite fiducial points.

### 4.2 Exterior Orientation

![Exterior Orientation tool](image)

This function ("Aerial Imagery → Exterior Orientation") computes the Exterior Orientation (EO) of the camera (Fig. 4). It describes the position and the angular orientation of the camera in the ground coordinates system at the time of exposure. It is composed of the spatial position which corresponds to the camera optical center coordinates, i.e., Easting, Northing, Altitude, and the angular orientation, which is composed of three rotation angles $\omega$, $\phi$, $\kappa$, and may be seen as the roll, pitch, and yaw of the focal plane. These six parameters are determined using space resection by collinearity (Ayoub et al. (2009), Wolf & Dewitt (2000)).

1. “Interior Orientation”: Select the file obtained during the Interior Orientation of the camera (Sec. 4.1).
2. “GCPS File”: Select the file containing the GCPS. This file can be obtained from (Sec. 7.2) or edited manually. It is an ASCII file which presents data in an array form. One GCP per line with a line composed of: longitude (decimal degree) latitude (decimal degree) altitude (meter) X (pixel) Y (pixel) SNR (0 to 1) [other]. SNR represents the weight of each GCP in the global EO computation. The file must contains at least three GCPS.
3. “Exterior Orientation”: Enter the name of the Exterior Orientation file to be created and click OK. The file will contain the six EO parameters: longitude (degree) latitude (degree) altitude (meter) $\omega$ (radian) $\phi$ (radian) $\kappa$ (radian). Note that $\kappa$ is given with the North as a reference, and can be seen as the sum of the aircraft azimuth and yaw. The EO file is then used during the image orthorectification (Sec. 9).

### 5 Satellite Imagery Specific

#### 5.1 Ancillary File

This function ("Satellite Imagery → Ancillary File → <Satellite to study>") rearranges the ancillary data of a satellite image into a common file format that will be used afterward in COSI-Corr. This ancillary file contains the positions, attitudes, and look directions of the satellite while acquiring the image, and other information such as the number of lines and columns, nominal ground resolution.

#### 5.2 Satellite specifics

**ASTER Imagery:** The level L1A is required. The ASTER .hdf file is expected as input. Although any band can be selected (VNIR, SWIR, TIR), it is recommended to use the band VNIR 3N (nadir viewing) for surface deformation detection.
Formosat-2 Imagery: The level 1A is required. Panchromatic and multi-spectral images can be processed. The METADATA.dim file is needed.

SPOT/SPOT5 Imagery: The level 1A is required. Panchromatic and multi-spectral images can be processed. Leader (lead.dat file) and Dimap (.dim) format are accepted. “Panchromatic with CCD correction” accounts for the slight misalignment of the CCD arrays in SPOT1-4. The correction is established empirically for each satellite, and is currently only available for the SPOT 2 HRV 1 and SPOT 4 HRV 1 instruments.

SPOT6-7 Imagery: The level 1A is required. Panchromatic and multi-spectral images can be processed. Note that only full scenes (not subsets) are accepted. The DIM_xxxx.XML file is needed.

Pleiades Imagery: The level 1A is required. Panchromatic and multi-spectral images can be processed. Note that only full scenes (not subsets) are accepted. The DIM_xxxx.XML file is needed.

Quickbird Imagery: The level 1B (Basic) is required. Panchromatic and multi-spectral images can be processed. Note that only full scenes (not subsets) are accepted. The files .eph, .att, .geo, and .imd (or the .xml) will be needed and must be located in the same folder (only one of these 4 files need to be entered in the “auxiliary file” field, the other ones being retrieved automatically).

Worldview Imagery: The level 1B (Basic) is required. Note that only full scenes (not subsets) are accepted. The files .eph, .att, .geo, and .imd (or the .xml) will be needed and must be located in the same folder (only one of these 4 files need to be entered in the “auxiliary file” field, the other ones being retrieved automatically).

6 Mars Imagery Specific

6.1 Ancillary File

HiRISE Imagery: The hi4socet.pl script will generate the raw image and a *keywords.lis which contains all the telemetry and geometric information of the image acquisition. The *keywords.lis is needed to generate the COSI-Corr ancillary file. Please see Sec. 6.2 for more details on pre-processing HiRISE image.

CTX Imagery: The mroctx4socet.pl script will generate the raw image and a *keywords.lis which contains all the telemetry and geometric information of the image acquisition. The *keywords.lis is needed to generate the COSI-Corr ancillary file of the CTX image.

6.2 HiRISE/CTX general process (pre-COSI-Corr)

Before HiRISE and CTX images can be used in COSI-Corr, the raw imagery need to be processed in a format compatible with COSI-Corr. This is done using ISIS and USGS scripts which will (for HiRISE):

- Reconstruct the full image from the 10 images stripes. These stripes were acquired by each of the 10 CCD arrays on the focal plane (since about 3 years, only 9 CCD arrays are operating).
- Extract of the telemetry and geometry of the image acquisition.
- Convert the reconstructed image from ISIS format (.cub) to a binary format interpretable by ENVI.

In practice these steps are carried out from the following steps:
1. Get the 10 (or 9) red band stripes of the HiRISE image of interest. These stripes can be either obtained from a HiRISE team member in the format of *.balance.cub (these *.balance.cub stripes are unfortunately not public, so one needs to contact a HiRISE PI), or generated from the EDRs publicly available from the HiRISE website (http://hirise.lpl.arizona.edu/). Refer to ISIS documentation for details (See paragraph "Batch processing" of EDR processing ⁸). The main difference between the two processing is a better color balancing between stripes with the balance.cub compared to the norm.cub.

2. Run hi4socet.pl on the *.balance.cub list or *.norm.cub list: Let’s assume that EDRs of HiRISE image ESP_028087_1890 have been downloaded from the HiRISE website, and that the stripes have been reconstructed following the ISIS recommendation. We’ll have the following files:

- ESP_028087_1890_RED0.norm.cub
- ESP_028087_1890_RED1.norm.cub
- ESP_028087_1890_RED2.norm.cub
- ESP_028087_1890_RED3.norm.cub
- ESP_028087_1890_RED4.norm.cub
- ESP_028087_1890_RED5.norm.cub
- ESP_028087_1890_RED6.norm.cub
- ESP_028087_1890_RED7.norm.cub
- ESP_028087_1890_RED8.norm.cub

You’ll notice that we only have 9 stripes instead of 10, as this image was acquired after CCD9 failure. Now run the USGS script by doing (command line):

$ ls *.norm.cub > normcube.lis
$ hi4socet.pl normcube.lis

The first command will create an ascii file containing all the stripes names. The second command will reconstruct an ideal full raw image. The process is quite long (few hours). Once done, the following files will be generated:

- ESP_018039_1890_REDMos_hijitreged.norm.noproj.8bit.cub
- ESP_018039_1890_REDMos_hijitreged.norm.noproj.cub
- ESP_018039_1890_REDMos_hijitreged_keywords.lis
- ESP_018039_1890_REDMos_hijitreged.raw
- ESP_018039_1890_STRETCH_PAIRS.lis
- flat.f0m1.txt
- flat.f1m2.txt
- flat.f2m3.txt
- flat.f3m4.txt
- flat.f4m5.txt
- flat.f5m6.txt
- flat.f6m7.txt
- flat.f7m8.txt
- hi4socet.prt
- hinoproj.prt

The files in red are the files needed to move to COSI-Corr. *.raw is the raw binary reconstructed image and *keyword.lis is a text file containing the ancillary information of the image.

3. Before opening the .raw in ENVI, you need to retrieve the number of lines and columns of the image. This information can be found in the *keyword.lis (keywords TOTAL_LINES, TOTAL_SAMPLES).

⁸http://isis.astrogeology.usgs.gov/IsisWorkshop/index.php/Working__with__Mars__Reconnaissance__Orbiter__HiRISE__Data
When opening for the first time the *.raw in ENVI, you will be asked to enter the header information of the image:

- **Samples**: number of columns (TOTAL_SAMPLES)
- **Lines**: number of lines (TOTAL_LINES)
- **Bands**: 1
- **Offset**: 0
- **Xstart**: 1
- **Ystart**: 1
- **File Type**: Envi standard
- **Byte Order**: Host (Intel). May depend on your OS/hardware
- **Data Type**: Byte
- **Interleave**: BSQ

Once entered, ENVI will create a .hdr, recording all these informations.

At that point, the image is ready to be processed in ENVI and COSI-Corr. The first step is to create a COSI-Corr ancillary file for the image. This is done from the COSI-Corr onglet in ENVI: Cosi-Corr → Satellite Imagery → Ancillary File → Mars → HiRISE (or CTX), and select the *keyword.lis that has been generated in the steps above. From there, you can follow the processing of earth based imagery as described in this user guide.

### 6.3 Notes on HiRISE/CTX specifics

- **If you are using HiRISE DTM and HiRISE orthos obtained from the HiRISE website, both datasets need to be opened in ENVI using: File → Open External File → MRO → HiRISE RDR. This is critical for the map projection information to be read properly. Do not use File → Open Image File on .IMG or .JP2 from HiRISE website.**

  HiRISE orthos are in JP2 format, with an associated .LBL file. The .LBL file (found along the JP2 on the HiRISE website) contains the map projection information of the image. It is mandatory and must be stored in the same directory than the JP2 file. HiRISE DTM map projection information is contained in .IMG format and doesn’t have a .LBL file.

- **HiRISE DTMs downloaded from the HiRISE website need to be cleaned from "missing" values. DTM border pixels are filled with the value -34e38, which will corrupt any subsequent processing. These values need to be replaced with more "plausible" values (e.g. average of the local topography, etc). To do that you can use the Cosi-Corr → Satellite Imagery → Ancillary File → Mars → Clean DTM tool. The average elevation of the scene will be computed and will replace "missing" values. Alternatively, you can replace the "missing" values by the value of your choice using Cosi-Corr → Tools → Discard/Replace Image Values. In both cases, do not forget to open the DTM to clean using File → Open External File → MRO → HiRISE RDR for the map information to be forwarded to the cleaned DTM correctly. Once the DTM is cleaned, you can save it as a regular ENVI file.

### 7 Tie Points and GCPS

#### 7.1 Tie points Selection

The tie points selection consists of pairing similar points between two images. It will most of the time consists in associating points between a georeferenced image and a non georeferenced image, typically between an orthorectified image and a raw image. It allows to associate a ground coordinates to a point in a raw image.

1. Open the two images for the tie points selection.
2. Select the “Tie Points/GCP → Select Tie Points: Image to Image” tool. “Base Image” refers to the georeferenced image (master), and “Warp Image” refers to the raw image (slave).

3. Select tie points between images. See ENVI Help for more details on this function.

4. When done, save your tie points selection using “File → Save GCPs” to ASCII (and not Save Coefficient to ASCII). The file created will be a list of the form \(x\) \((\text{master})\) \(y\) \((\text{master})\) \(x\) \((\text{slave})\) \(y\) \((\text{slave})\) in pixel.

**Note 1:** This is an ENVI function that can also be found in “Map → Registration”. The ENVI tool accounts for the xstart and ystart contained in the image header. Make sure they are set to 1, as COSI-Corr assumes so. Most likely, this will not be the case if your georeferenced master image is a subset of a larger image, that has been cropped using ENVI. Editing the header of your master image and forcing the xstart and ystart to 1 will not corrupt your data and is mandatory.

**Note 2:** If tie points are selected (between an orthorectified image and a raw image) to be converted to GCPS and optimized, here are some guidelines to pick them adequately:

- At least three points must be selected. If the warp image is to be co-registered with a shaded DEM, a larger number of points (15 to 30 if possible) should be selected to average the probable correlation errors due to the difference in images content.
- Spread the points as much as you can in the image, but select them away from the area where surface displacement is expected. If displacement is expected in the whole image, select points in areas of smallest displacements.
- Do not select points too close to the images borders. As the optimization will correlate windows centered on each point, the optimization window size should be kept in mind when picking tie points.
- Pay attention to the points surrounding. Are features recognizable between the two images? Try to select points whose neighborhood contain easily identifiable features or patterns. Are there any temporal decorrelations (man made changes, shadowing differences, …)? Prefer areas of low topography to minimize uncorrected stereoscopic artifact.
- It is not necessary to select tie points precisely as the optimization will correct them. With the frequency correlator, the maximum placement error allowed on the initial GCPS will correspond to half the correlation window size. With the statistical correlator, a search range will have to be defined.

### 7.2 Tie points to GCPS

![Figure 5: Tie points to GCPS transformation tool](image)

This function (Tie Points/GCP → Tie points to GCPS) converts a set of tie points into GCPS (Fig. 5).
1. “Tie Points File”: Select the file containing the tie points between the two images. The file must be of the form x (master) y (master) x (slave) y (slave) in pixel. This file is typically generated by the “Tie Points Tool” (Sec. 7.1), but you can edit it manually.

2. “Reference Image”: Select the image used as a reference (master) during the tie points selection. The image must have a map information, and is typically an orthorectified image. The geographic coordinates will be retrieved from its map information.

3. “DEM File”: Select a DEM with a valid map information to retrieve the altitude of the GCPS. If not entered, the altitude will be set to 0.

4. “Offset field”: If selected this field must receive a file whose first and second bands contain a displacement map of the area in East/West and North/South direction respectively (a correlation map typically). The displacement found at the GCP location is retrieved and added to the GCPS file. This information will be used in the GCPS optimization (Sec. 8) as this displacement will be accounted for during the optimization. For example, a SPOT based displacement map can be used to account for the ground displacement at GCP location while co-registering aerial images (Ayonib et al. (2009)).

5. “GCPS File”: Select the name of the GCPS file to be created.

The format of the GCPS file created is (Fig. 6): longitude (decimal degree) latitude (decimal degree) altitude (meter) X (pixel) Y (pixel) SNR (0 to 1) OPTI (0 or 1) DX (meter) DY (meter) DZ (meter). SNR, set to 1 by default, can be changed manually if needed and is used during the orthorectification and the GCPS Optimization. It represents the weight of the GCP. OPTI, DX, DY, DZ are used for the GCPS Optimization only. See Sec. 8, Sec. 9.1 for more details.

![Figure 6: GCPS text file format](image)

### 8 GCPS Optimization

Even with all the care taken during manual tie points selection (converted then to GCPS), the orthorectified image usually presents a misregistration with the reference image, at the GCP’s location. To get a better co-registration, GCPS are refined using the following process:

1. The raw image EO (aerial)/Look Angles (satellite) are computed using the GCPS.

2. The raw image is ortho-rectified and correlated with the reference image.

3. At each GCP location, the GCP ground coordinates are corrected by the ground offset found between the images.

4. The process is iterated with the corrected set of GCPS until convergence of the ground offset correction.
This function (Aerial Imagery or Satellite Imagery → GCPS Optimization → GCP Optimization) optimizes a raw image GPCS with respect to a reference orthorectified image to achieve a good co-registration (Fig. 7).

Figure 7: GCPS optimization parameters selection tool

1. “Raw Image”: Select the raw image whose GCPs are going to be optimized.
2. “Reference Image”: Select the orthorectified image onto which the raw image will be co-registered. This image corresponds generally to the first orthorectified image of the pair, a shaded DEM, or an external orthorectified image. The reference must be georeferenced in the UTM projection.
3. “DEM”: Select the DEM that will be used to correct the topographic effects during the optimization. If selected, the DEM must be georeferenced and can be of any projection. If not selected, the topography will be considered flat at altitude 0 (above the ellipsoid WGS 84). It is strongly recommended to use the same DEM that was used to orthorectify the reference image as DEM errors will then be kept consistent between the two images. In case of an optimization with a shaded DEM, the DEM used should be the one used to generate the shaded DEM.
4. “Ancillary/IO file”: Select the ancillary file (for satellite) or the Interior Orientation file (for aerial) of the raw image.
5. “GCPS/tie points/ICP”:
   - GCPS: A GCPS file is the most flexible option. This is a file (Fig. 6) whose format is longitude (decimal degree) latitude (decimal degree) altitude (meter) X (pixel) Y (pixel) SNR (0 to 1) OPTI (0 or 1) DX (meter) DY (meter) DZ (meter) and contains at least three GCPS (obtained generally from the Tie points to GCPS tool (Sec. 7.2)).
SNR represents the weight of the GCP (between 0 and 1). If the confidence is similar for all points, all SNR should be equal and different than zero.

OPTI is a flag indicating whether the GCP is going to be optimized (1) or not (0). A GCP with the OPTI flag set to 0 will be accounted for during the computing of the EO (aerial) or Look Angle correction (satellite) but not optimized. A typical example where GCPS should not be optimized would be some GPS points located precisely, whereas others GCPS are coarsely estimated. Another example would be a feature clearly recognizable between the reference image and the raw image (during tie points selection) but with a surrounding of poor quality content that may bias the correlation if optimized. Although rarely used, this option can be useful when dealing with heavy snow or heavy cloud cover.

DX, DY, DZ are used to account for a ground/surface displacement sustained at the GCP location. They refer respectively to the displacement in Easting, Northing and Elevation in meter (currently the Elevation displacement is not used). If values are entered, the GCP will be optimized in order to co-register the images while accounting for the displacement entered at the GCP location.

- **Tie points file**: This is a file whose format is \(x \ (\text{ref}) \ y \ (\text{ref}) \ x \ (\text{raw}) \ y \ (\text{raw})\), and is usually generated with the ENVI tie points selection tool (Sec. 7.1) or edited manually. The reference image and raw image used for the tie points selection must be the same as the ones entered in the GCPS optimization windows. Tie points will be converted to GCPS prior to optimization. Note that if the tie points file is edited manually, pixels coordinates contained in the file must be expressed with the convention where the first pixel coordinates are (1,1) to stay consistent with the ENVI points selection process.

- **ICP**: Image Control Points. This option is available only for satellite imagery. It is a file whose format is \(x \ (\text{raw}) \ y \ (\text{raw})\). The points do not need to be tied to a reference image as the ancillary data are accurate enough to locate them geographically. Points will be converted to GCPS prior to optimization. This option can be used with SPOT 5 but is not recommended with SPOT 1-4 and ASTER images. Unlike the tie points file, pixels coordinates must be expressed in a coordinates system where the first pixel coordinates are (0,0).

Note that the weighting of the GCPS, the OPTI flag, and the DX, DY, and DZ fields are only available through the use of a GCPS file (and not a tie points or ICP files).

6. Optimization Options:

(a) “Nb Iterations”: Number of loops that will be executed to optimize the GCPS. 5 loops are usually enough to reach stable convergence. If the optimized GCPS file report shows that the convergence is not reached, the process should be continued. Continuation of the process can easily be done by giving as GCP input file the output file where convergence is not reached.

(b) “Resampling kernel”: Select the resampling kernel that will be used to resample the raw images patches. This option is similar to the one described in (Sec. 9.1).

(c) “Correlator engine”: Select the correlation method used to correlate the patches and retrieve the displacements to correct. Usually a window size of 128 or 256 pixels is used. It will allow for a good co-registration on the long wavelengths. The statistical correlator is advised when the reference image is the shaded DEM, whereas the sequential correlator is advised when the reference image is an orthorectified image. For more information on the correlator engines and their options, see Sec. 10.

(d) “Weight GCP with correlation SNR”: If checked, GCPS will be weighted with the correlation SNR of the previous loop. This allows to give more weight on GCPS whose patches have a better correlation. For the initialization, GCPS will be assigned the SNR read from the GCPS file or assigned an equal SNR in case of “tie points” and “ICP” files. If not checked, GCPS will be constantly weighted with the SNR from the initialization.
(e) “Dynamic display of optimization”: If checked, a graphic window displaying the successive patches will be displayed as the optimization goes. This allows for a visual check of the patches that are correlated. For instance, it is a convenient way to check that GCPS have not been chosen too close to the images borders.

7. “Optimized GCPS”: Select the filename of the optimized GCPS that will be created.

The “Select All” button allows you to select successively all the files necessary.

Besides the optimized GCPS, the output file will also contain a record of the files and parameters used, as well as information on the optimization. The average and standard deviation of the mis-registrations, in each North/South and East/West component, are recorded at each iteration. This allows to check the convergence of the process and the quality of the GCPS generated. A residual misregistration as small as possible is desired.

Note that if the GCPS were optimized with a Tie Points file, the x and y pixel coordinates of the optimized GCPS are minus 1 compared to the initial coordinates. COSI-Corr is using a pixel coordinates system originating at (0,0), unlike ENVI, which starts at (1,1).

8.1 Miscellaneous

When optimizing GCPS generated from tie points selection between an aerial image and a shaded DEM, if the difference in resolution is large (example: 1 m image vs. 30 m SRTM), or if the topographic features are too small for a good optimization, it is recommended to geolocalized first a satellite image with the shaded DEM, and use the subsequent orthorectified satellite image as a reference.

9 Orthorectification and Resampling

This function will orthorectify an image (“Aerial Imagery or Satellite Imagery → Orthorectification/Resampling”). It is composed of two steps: The pixel mapping between the raw image and the futur orthorectified image, and the resampling of the image according to the mapping.

9.1 Orthorectification

1. “image to orthorectify”: Select the raw image to orthorectify. You can define a Spatial Subset, i.e., select a subset of the image that you want to orthorectify. You can select also a Spectral Subset, i.e., select the bands of the image you want to orthorectify in case the image is multi-band (by default all the bands are orthorectified).

2. “Ancillary data file” (satellite), or “IO file” (aerial): Select the data file corresponding to the image to orthorectify.

3. “EO or GCPS file” (aerial), or “GCPS file” (satellite)
   - Aerial image: Select the EO file or the GCPS file. In case of GCPS file, the EO will be computed prior to the matrices computation.
   - Satellite image: Select the GCPS file. If not selected, the orthorectification will only use the ancillary data file to orthorectify the image. The accuracy will therefore depends on the satellite ancillary data accuracy.

4. “DEM”: Select the DEM file to account for the topography. The file must have a valid map information and can be in any projection. If not entered, the orthorectification will take place assuming a flat topography at altitude 0 (above the ellipsoid WGS 84).
5. Map Grid: Define the projection and ground grid of the orthorectified image. Note that the datum of the projection must be the same as the datum of the DEM (if used). Three options are available to define the grid:

- “From Raw image”: The ground footprint is defined from the raw image size and subset if a Spatial Subset was defined during the image selection.
- “From Georeferenced image”: Select an existing georeferenced image to define the cartographic projection and ground footprint and resolution. It is possible to Spatial Subset the georeferenced image to reduce the ground footprint. This option is useful when orthorectifying the second image of a pair that needs to be correlated. Selecting the orthorectified first image of the pair guarantees that ground footprint and resolution are identical.
- “Manual Edit”: Select/modify manually the grid.

**Note:** In the Grid Parameters window, the button “Adjust grid to be multiple of resolution” forces the grid corners to be multiple of the ground resolution selected. This action guarantees that all orthorectified image of the same resolution can be aligned exactly (pixel-wise).

6. “Save warping matrice”: If desired, the mapping between the raw image and the orthorectified image can be saved.
7. “Resampling Kernel”: Three resampling kernels are available. Bilinear, Bicubic and Sinus Cardinal (Sinc). The bilinear and bicubic kernel do not accept any parameters and are somewhat faster than the Sinc. The Sinc is a more precise resampler than the two other kernels. It is recommended to use the Sinc kernel for an improved resampling quality and ultimate correlation. Default kernel size is 15 pixels, which you can adjust through the “Option” button. The kernel size represent the number of sinc lobes computed. Larger kernel window size provide a better resampling but are longer to compute. Improvement in the resampling quality for kernel size larger than 15 pixels are negligible.

8. “Output”: Select the file name of the orthorectified file to create. You can save the file in memory only if you want.

10 Correlation and Displacement Measurements

![Correlation parameters selection tool](image)

This function (“Correlation”) correlates two images and provides a map of the relative displacements (Fig. 9).

1. “Pre-event Image”: Select the first image of the pair. This image is considered the reference.

2. “Post-event Image”: Select the second image of the pair. The correlation result provides a displacement field using the convention eastward and northward positive. This displacement field is the horizontal ground displacement that should be added to the pre-event image to retrieve the post-event image.

3. Correlator engine: Select the correlator engine. Currently two correlators are available: frequency (Sec. 10.1), and statistical (Sec. 10.2). The frequency correlator is Fourier based and is more accurate than the statistical one. It should be use in priority when correlating optical images. However this correlator is more sensitive to noise and is therefore recommended for optical images of good quality. The statistical correlator maximizes the absolute value of the correlation coefficient and is coarser but more robust than the frequency one. Its use is recommended for correlating noisy optical images that provided bad results with the frequency correlator, or for correlating images of different content such as an optical image with a shaded DEM.

4. “Correlation File”: Select the name of the correlation file to be created.
If both images are georeferenced with the same projection and resolution, the georeferencing is accounted for, and only the geographic overlapping part is correlated. Otherwise, the correlation is pixel based.

## 10.1 Frequency Correlator

![Frequency Correlator Parameters](image)

Figure 10: Frequency correlator parameters

The frequency correlation is a two step process. The first step consists in roughly estimating the pixelwise displacement between two patches. Usually in noisy images or when large displacement are expected, the initial window is set up to large size. In theory the window size should be at least twice the expected displacement, but in practice we recommend a larger ratio (i.e., use a 128 or 256 initial window size with an expected displacement of 15 pixels). Once the initial displacement is estimated, a second, final correlation is operated to retrieve the subpixel displacement. It is customary to select for the final window size the smallest size that will provide a reasonable amount of noise (from experiment, a window size of 32×32 pixels is the minimum and a window size of 32×32 or 64×64 usually yields good results with good quality images) as it will increase the density of totally independent measurements.

The parameters for the frequency correlator are (Fig. 10):

1. **“Window Size Initial”**: Size in pixels in X and Y direction of the initial sliding window that will estimate the pixelwise displacement between the images. The size is a power of two.

2. **“Window Size Final”**: Size in pixels in X and Y direction of the final sliding window that will compute the subpixel displacement between the the images. The size is a power of two.

3. **“Step”**: This parameter determines the step in X and Y direction, in pixels, between two sliding windows. If the step is greater or equal to the final window size, then all measurements are independent.

4. **“Robustness Iteration”**: Number of times per measurement the frequency mask should be adaptively re-computed. The mask contributes in reducing the noise on the measurements. 2 to 4 iterations is satisfying in most cases Leprince et al. (2007).
5. “Mask Threshold”: Allows the masking of the frequencies according to the amplitude of the log-cross-spectrum. A value close to unity is appropriate in most cases. See Leprince et al. (2007) for more details.

6. “Resampling”: Patches to correlate are relocated from sinc resampling. This option theoretically eliminates most of the biases at the sub-pixel scale. If used, the processing time is greatly increased (on average by a factor of 10). However, on noisy images, its usefulness has been noticed only on a very few occasions.

7. Grided Output: Check this option if you want to obtain a displacement map with the top-left corner coordinates to be integer multiple of the ground resolution. This is mostly useful when several correlation of the same area need to be overlaid or mosaiced. If unckeck the top-left corner coordinates of the displacement map will be identical to the top-left corner coordinates of the master image.

10.2 Statistical Correlator

The parameters for the statistical correlator are (Fig. 11):

1. “Window Size”: Size in pixels of the patches that will be correlated, in X an Y direction.

2. “Step”: This parameter determines the step in the X and Y direction, in pixels, between two sliding windows. If the step is greater or equal to the window size, then all measurements will be totally independent.

3. “Search Range”: maximum distance in the X and Y direction in pixels where the displacements to measure are to be searched.

4. “Grided Output”: Check this option if you want to obtain a displacement map with the top-left corner coordinates to be integer multiple of the ground resolution. This is mostly useful when several correlation of the same area need to be overlaid or mosaiced. If unckeck the top-left corner coordinates of the displacement map will be identical to the top-left corner coordinates of the master image.
10.3 Batch Correlation

In situation where a lot of correlations have to be processed, the manual selection of the correlation parameters through the COSI-Corr GUI can be tedious. Batching all the correlations using text files for the input parameters is possible. Basically, the user will feed 4 text files (ascii format) containing the list of master, slave, correlation parameters, and output correlation file names to the batch correlation function. Note that the correlation parameters and correlation filenames files are optional (see below). The execution of the batch can be operated through the COSI-Corr GUI or through the IDL/ENVI command line as explained below.

10.3.1 Batch Correlation input parameters

The ascii formats of the text file are the following:

- **Master file:**
  This file is mandatory. One image per line, and for each image (line) the number of elements can be either 1, 2, or 6:
  - 1-element: filename (full path). The first band and full extent of the image will be correlated. For instance:
    `/home/johnMclane/studyCase/master.tif`
    `/home/johnMclane/studyCase2/master.tif`
    `/home/johnMclane/studyCase3/master3.tif`
  - 2-elements: filename (full path) + band number (first band = 1). This allows to select the band to be correlated. This is only useful for multiband image and when the band to correlate is not the first band. Full extent of the image will be correlated. For instance:
    `/home/johnMclane/studyCase/master.tif 1`
    `/home/johnMclane/studyCase2/master.tif 2`
    `/home/johnMclane/studyCase3/master3.tif 2`
  - 6-elements: filename (full path) + band number + spatial extent (Xstart, Xend, Ystart, Yend). This allows to select a subset of the master image to correlate. The spatial extent is expressed in pixel (top-left pixel coordinates are (1,1)). For instance:
    `/home/johnMclane/studyCase/master.tif 1 500 2564 758 6225`
    `/home/johnMclane/studyCase2/master.tif 2 1 500 1 700`

A given master text file can use the three options (1,2,6-elements):

- Slave file:
  This file is mandatory. Same layout and options as the master file.

- Correlation Options file:
  This file is optional. If not used, the correlation parameters by default will be applied (Frequential correlation using a 64x64 pixels correlation window size and a step of 16 pixels). The layout for customized correlation parameters are the following:

For instance:

\begin{verbatim}
frequency 64 64 32 16 16 4 0.9 0 1
frequency 64 64 64 64 4 4 4 0.9 0 0
statistic 32 32 16 16 7 7 1
statistic 10 10 2 2 10 10 0
\end{verbatim}

- Correlation filenames file:
  This file is optional. If not entered, the correlation file will be stored in the slave file directory and will be named `correlation_masterFileName_vs_slaveFileName_id`, with `id` being the correlation number of the batch. If entered, the file contains the full path of the correlation file name (one file name per line).

Master, Slave, Correlation Options, and Correlation Filenames files must have the same number of lines. However there is one exception. It is possible for Master, Slave and Correlation Options files to have only one line although the other files have more lines. This indicates that the single line parameters is to be applied to all correlations of the batch. For instance, if Master file has one line and Slave file has 10 lines, there will be 10 correlations, one master image to be correlated with the 10 slave images. Similarly, if the correlation file has only one line, the same correlation parameters will be applied to all correlations.

### 10.3.2 Batch Correlation execution

The batch correlation can be executed through IDL/ENVI command line:

```
ENVI> cosi_batch_correlation, masterFile, slaveFile, CORR=corrFile, OUT=outFile, NO_OPEN=no_open
```

For instance:

```
ENVI> cosi_batch_correlation, '/home/johnMclane/studyCase/master.txt', '/home/johnMclane/studyCase/slave.txt', CORR='/home/johnMclane/studyCase/correlations.txt', OUT='/home/johnMclane/studyCase/correlationNames.txt'.
```

By default, the procedure opens the master, slave, and correlation files in ENVI. If set, the NO_OPEN keyword does not open the files (to set the keyword enter in the commande line NO_OPEN=1. Default is NO_OPEN=0).

Alternatively, the batch correlation can be executed through the COSI-Corr GUI: COSI-Corr → Correlation → Batch Correlation, which will ask successively for the Master, Slave, Correlation Options and Correlation Filename files. If not providing a Correlation Options or Correlation Filename files, just click “Cancel”.

### 11 Tools

#### 11.1 Non Local Means Filter

This tool (“Tools → Non-Local Means Filter”) is an implementation of the Non-Local Means algorithm for denoising datasets and images. This algorithm (Buades et al. (2008)) and its derivatives (Buades et al. (2006), Goossens et al. (2008), Zimmer et al. (2008)) have demonstrated an exceptional ability to preserve fine detail while reducing additive white Gaussian noise. The most common application of the non-local means algorithm is to the restoration of digital images. The implementation provided here extends the method to denoising of scientific data sets in general. A number of modifications to the original filter have been introduced in the literature. We have chosen to implement modifications proposed in (Buades et al. (2006), Goossens et al. (2008)). Major features of our implementation include:

- Highly optimized native code that transparently and automatically exploits parallelism and media extension instructions for rapid processing of data sets (SIMD instruction set).
- Optional use of signal-to-noise weighting metrics for enhanced denoising.
- Ability to account for the presence of missing values (NaN) present within the input data set.

11.1.1 Filter Process

The non-local means algorithm filters data by stepping through the data set one value at a time. At each data point, a small region of surrounding values (typically 5x5 or 7x7) is compared with other non-local regions (patches) of the same size. A larger region around the central patch is used as the search area. The filtered value is computed as an average of the values within the search area, weighted by their measure of similarity with the patch centered at the pixel to be filtered. This approach has the effect of preserving true signals and features.

![Non-Local Means Filter](image)

Figure 12: Non-Local Means Filter

1. “Bands to filter”: Load one or more bands to be filtered (Fig. 12).
2. “SNR file(optional)”: A band weighting (signal-to-noise ratio) can be selected and applied during filtering. The SNR file must have the same spatial size as the bands to be filtered, should be floating point values comprised between 0.0 and 1.0, and will be applied to all bands selected.
3. Upon loading, the bands have been automatically assigned default filter parameters (see 11.1.2, 11.1.3 for parameters details). Each band is associated with its own set of filter parameters and can therefore be processed with a set of data-specific parameters (if the user wishes). Clicking on a band name in the band list causes the parameter controls to be updated with that band’s particular parameter set. NOTE: The user must supply a noise parameter for each band since this parameter has no default value. All other parameters may be left at their default settings if so desired.
4. “Filtered bands file”: Select the name of the filtered bands output file. The filtered bands are automatically assigned the same names as the originals, but in addition have “_NLMfiltered” appended to the end of them. In addition, the header file will list the filter parameters for each band. NOTE: During processing, the ENVI/IDL user interface is unresponsive. A progress bar is displayed that increments after each band has been filtered.

11.1.2 Filter Parameters (Fig. 12)

H (noise parameter): This number is used to control the degree of denoising and is proportional to the standard deviation of the noise. A common value for H is between 0.5 and 2 times the standard deviation of the noise, and it depends on the other parameters selected. The stronger dependencies are on the weighting type (Standard, Bisquare, or Modified Bisquare), and on whether the “center data point” is omitted or not, in the advanced parameters. With the default parameters, a value of H close to 1.6 times the noise estimated standard deviation is a good estimate.

This parameter does not have a default value. Therefore the user MUST supply a noise parameter for each band prior to running the filter. The noise standard deviation can be estimated from the image local statistics, observed over areas with presumably constant values. The ENVI ROI tools can be conveniently used to this end.

Search area dimension: This number refers to the dimensions of the search area around each data point. Since the shape of the area is fixed as a square, the user need only supply one value indicating the dimension of the side. For example, if the user enters “17” this instructs the application to use a search area of size 17 x 17 pixels. The default value is 21, corresponding to a search area of 21 x 21 data points. This value must be an integer smaller than the smallest data set dimension. CAUTION: Large search areas will cause the application to be unresponsive for long periods of time. In general, areas sizes from 21 x 21 to 41 x 41 pixels produce good results at acceptable execution times.

Patch size: This selection refers to the dimension of the square patch used to characterize the area surrounding each data point. The choices are limited to 5x5 or 7x7. The default selection is 5x5.

Weighting method: This selection refers to the method by which the final value is ultimately computed.

Averaging: The denoised value is determined by a simple weighted average of the pixels comprised in the search area. This is the default setting.

Linear regression: The denoised value is determined by weighted linear regression of the pixels within the search area.

11.1.3 Advanced Filter Parameters (Fig. 13)

Minimum weight value: Only used if the “Linear regression” weighting method is selected, otherwise it is ignored. Only weights above this threshold will be counted in the “minimum number of weights” computation. This sanity check ensures that very small weights are not counted as part of a valid averaging. The default value for this field is 0.1. This value must be a floating point between 0.0 - 1.0. The closer this parameter is to zero, the more the linear regression filtering will occur, with the risk of fitting the noise for pixels with very few similar patches in the search area. The closer this parameter is to one, the less the linear regression filtering will occur, defaulting to the standard averaging method.

Minimum # of weights: Only used if the “Linear regression” weighting method is selected, otherwise it is ignored. Minimum number of weights above the “minimum weight value” threshold so that the “Linear regression” filtering can occur. Otherwise, the filtering method defaults to the “averaging” filtering method. This condition avoids fitting the noise when only very few significant weights exist in the search area. This parameter therefore only makes sense if it is larger than three. If it is too large, linear regression filtering tends to occur less, defaulting to the standard averaging method.
**Center data point:** Indicates whether or not the center data point (i.e., the data point being filtered) is included in the weight calculation. The default condition is to omit the center data point in the weighting calculation.

**Noise parameter:** Indicates whether the noise parameter $H$ is fixed at the user supplied value. Otherwise, an adaptive algorithm (Zimmer et al. (2008)) is used to select the noise parameter at each filtering point. This adaptive method works poorly and it is not advised to use it, but it is left here for further tests and developments.

**Weighting type:** Refers to the way the local weights relate to the patches similarity measurements.

- **Standard:** Computes the patch weights according to a Gaussian distribution (Buades et al. (2008)).
- **Bisquare:** A modified form of “Standard” with a finite taper and steeper fall-off (Goossens et al. (2008)).
- **Modified Bisquare:** A modified form of “Bisquare” but with even steeper taper and fall-off (Goossens et al. (2008)).

The “Standard” (i.e. Gaussian) and the “Bisquare” methods have proven to be the most useful in our tests. Note that for a given noise level in an image, a particular value of “$H$” has to be selected for each method.

**NOTE:** The denoising results provided by the filter, using the default parameters may not be appropriate for a given data set. In these cases the results will be sub-optimum and it becomes necessary to modify the optional parameters so as to achieve optimum denoising. Any combination of parameters is possible, with the following two exceptions: “Minimum weight value” and “Minimum # of weights”. These two parameters only take effect if the user has selected “Linear” as the weighting method. Otherwise they are ignored and changing their values will not affect the results. To speed-up parameters adjustment during trials and errors, note that a spatial subset of the image to be filtered can be selected. Then the filter is only applied on this image subset.

**11.2 Image Detrending**

This tool (“Tools → Image Detrending”) removes a polynomial trend in an image. In essence, a polynomial surface is fitted to the image and then removed from the image. By default, the polynomial fit is done on
the entire image. It is possible to spatially subset the area onto which the fit should be computed, either from the ENVI spatial subset tool and/or through the ROI tool:

1. Select the bands to detrend. This is done by using the “Spectral Subset” button of the ENVI File selection tool (Fig. 14). Default is to detrend all the bands.

2. Select the spatial subset used to compute and apply the detrending (Fig. 15 left). This is done using the “Spatial Subset” button of the ENVI File selection tool (Fig. 14). Default is to compute the polynomial fit and apply it to the full image extent.

3. It is possible to define the area used for computing the polynomial fit through a ROI selection. The ROI is selected in the “Spatial Subset” GUI (Fig. 15 left) by clicking on the “ROI/EVF” radio button and selecting the ROI of interest (Fig. 15 right). For instance, Figure 16 shows a ROI (red area) used to define the polynomial fit from. Note that the ROI must be defined before using the detrending tool.

4. Once the spectral and spatial subset and optional ROI are selected, the main GUI detrending GUI is displayed (Fig. 17):

---

Figure 14: Spectral and Spatial selection tool for image detrending

Figure 15: Spatial subset and ROI selection tool for image detrending
Figure 16: Exemple of area selection through ROI to define the polynomial fit

- Decimation step (pix): The definition of the polynomial fit can involve a lot of memory (RAM). To limit the memory footprint, this field allows to “decimate” the image prior to fitting the polynomial surface. A decimation step of 10 for instance means that only 1 pixel out of 10 (in column and row) are selected for the definition of the polynomial fit.

- Polynomial fit degree: Degree of the polynomial surface to fit to the image and subtract afterward from the image. A degree of 1 means that a plane will be defined.

- Fit iteration: This parameters limits the influence of the outliers which can bias the polynomial fit. Once the polynomial fit is operated, all pixel for which the residual (between the image and the fit) is larger than the standard deviation of the residuals are filtered out, and a new fit is operated on the filtered image. This process is operated as many times as defined by the user. Note that it is not recommended to set up a large number of iteration as once the largest outliers are removed, this process will start removing valid data (over-filtering).

- Save non-detrended bands: Check the box if you want the output file to contains bands that are not detrended, i.e., simple copy of the non-detrended bands of the image

11.3 Image Warping

This tool allows you to warp an image (slave) to another image (master) according to a set of tie-points between the master and slave image, or according to a correlation map obtained between the master and slave. Both methods are a 2-steps processes: the first step defines the mapping of the warping according to the tie-points or correlation map, and the second step resamples the slave according to the mapping defined in the first step.

11.3.1 Image warping from tie-points

Refer to Figure 18 left panel.

1. “Slave Image to Warp”: Select the slave image to be warped according to the tie-points defined between the master and the slave. The user can select the bands to warp (default is to warp all bands) and can select a spatial subset of the slave to warp. In case of a spatial subset, all the tie-points present in the tie-points file are used to define the warping, even those outside the spatial subset, but only the spatial subset is warped according to the mapping.
2. “Master Image”: Select the master image onto which the slave image is going to be warped on. Normally tie-points are selected between this image and the slave image selected previously. The master grid defines the grid of the warped slave. The user can change the grid onto which the slave will be warped on using a spatial subset.

3. “Tie-points file”: Select the tie-points file (ascii format). The format of the file should be one tie-point per line with the format of a line: $X_{-master} \ Y_{-master} \ X_{-slave} \ Y_{-slave}$. Coordinates are in pixels. A graphical tool to select the tie-points between the master and slave image is available at COSI-Corr $\rightarrow$ Tie-points/GCPS $\rightarrow$ Select Tie-points: Image to Image, or at Map $\rightarrow$ Registration $\rightarrow$ Select GCPS: Image to Image.

4. Select the warping function, either a Thin-plate spline (needs at least 7 non-colinear tie-points) or a polynomial surface fit.

5. The mapping matrix defined from the tie-points and the function used can be saved if needed, either on disk or in ENVI memory (beware of potential large size of the mapping matrix).

6. Select the resampling kernel used to resample the slave image according to the mapping. Options are described in Sec. 9.1.

7. Select the warped slave output type, either on disk (need to provide a file name) or in ENVI memory.

Note that this function is very similar to ENVI function Map $\rightarrow$ Warp from GCPS: Image to Image, with the added Thin-plate spline fit and sinc resampler option.

11.3.2 Image warping from correlation

Refer to Figure 18 right panel.

1. “Slave Image to Warp”: Select the slave image to be warped according to the correlation between a master and the slave images. The user can select the bands to warp (default is to warp all bands) and can select a spatial subset to warp.
2. “Correlation file”: Select the correlation file. It is expected that the first band selected is the E/W (column) displacement, and the second band selected is the N/S (line) displacement. If the master or slave image is not georeferenced (or if their georeferencing projection is different) the correlation must be processed with the Gridded Output unchecked (see Sec. 10). If both the master and slave image have an identical map projection (ground footprint can be different, but projection have to be the same), the Gridded Output box can be either checked or unchecked.

3. “Output grid”: Select the output footprint of the warped slave. Usually the master image (or a subset of it) is selected here. However, for georeferenced images, it is sometime desired to keep the ground footprint of the slave image, in which case select the slave image to defined the output ground grid. Note that in case of non-georeferenced image, the output grid must be defined from the master (or subset of it).

4. Warping options:

   - “Dense warping from the correlation”: If selected the slave will be warped according to the correlation map values around each pixel of the slave image. Conceptually, this option corresponds to an independent warping of each pixel according to the correlation map values. Note that it is recommended first to clean the correlation from outliers and replace NaN values with plausible values (e.g., median filtering).

   - “Polynomial fit from the correlation”: This option fit a polynomial surface to the correlation maps and warp the slave image according to this polynomial surface fit. Please refer to Sec. 11.2 for
information about the polynomial fit options.

5. The mapping matrice defined from the correlation map can be saved if needed, either on disk or in ENVI memory (beware of potential large size of the mapping matrice).

6. Select the resampling kernel used to resample the slave image according to the mapping. Options are described in Sec. 9.1.

7. Select the warped slave output type, either on disk (need to provide a file name) or in ENVI memory.

11.4 Discard/Replace Image Values

![Figure 19: Band parameters selection tool for image filtering](image)

This tool (“Tools → Filter Image Values”) allows you to filter and change pixel values in an image based on their values. The file can contain several bands. Typically, this function is used to filter out outliers or values with a weak SNR in a correlation file.

1. Select the file and the bands of interest. Non selected bands will not be changed.

2. For each band selected, enter the “minimum”, “maximum” and “replace” values (Fig. 19).

3. Select a file name if you want to save the filtered file on the disk or leave the field empty for in-memory load.

Every pixel in the band whose value is smaller than the “minimum” or larger than the “maximum” will be assigned the “replace” value. Note that for a pixel in a band changed, pixel at the same location in the other bands selected will be changed too by their respective “replace” value.

11.5 Destripe Image

This tool (“Tools → Destripe Image”) allows you to remove parallel stripes and undulations in an image. A typical use for this tool is the removal of undulation artifacts in a correlation image due, for example, to an uncorrected attitude like an oscillating pitch or a CCD array artifact in ASTER or SPOT images. The main idea is to average the artifact by stacking and subtracting the average to the image.

Two functions are available and are described below. The “Manual Orientation” allows to destripe any image, but the user needs to supply manually the rotation angle necessary to align vertically the undulations/strips to remove. The “Automatic Orientation” defines automatically the affine transformation necessary to align the undulations/strips before performing the stack. However it requires the user to identify which image (master or slave) is responsible to the undulations/strips to be removed, as the transformation is defined from the ancillary file and GCPS file (optional) of the image responsible for the undulations/strips. In case where the along-tracks are aligned and identification of the image responsible to the undulations/strips is difficult, either image (slave or master) can be picked.
11.5.1 Manual Orientation

1. “Image to define correction from”: Select the bands (usually only the EW and NS bands) from which the correction will be defined (Fig. 20).

2. “Angle to rotate image”: The stripes stacking is operated vertically. If the stripes are not vertical, the image must be rotated to align vertically the stripes. Enter the rotation angle (degree) necessary to align the stripes vertically. Tip: the ENVI rotate tool (“Basics Tools → Rotate/Flip Data”) can be used first to determine precisely the angle.

3. “Image to apply the correction to (if different)”: If the corrections are meant to be applied to a file different than the one they are determined from, select it accordingly. It must be of the same size, with the same number of bands that the file used to determine the correction. A typical case is when a denoised and smoothed correlation file is used to determine the stripes correction, but the correction is applied to the raw correlation file. If this field is left empty, the correction will be applied to the file from which the correction is determined.

4. “Corrected File”: Select the filename to create if you want to save it to the disk. Otherwise, leave the field empty for in memory computation, but keep in mind the size of the image in regards to the available dynamic memory.

5. Click OK

6. After a short computing time, a rotated image with the undulations aligned vertically will be loaded in memory. Select the file and select the spatial subset that will be stacked to determine the correction (Fig. 21). The same spatial subset will be stacked on each selected band.

7. Click OK
8. The output image will be the original file with the selected band corrected. The correction applied to the bands is appended as additional bands at the end of the file. The non selected bands remain unchanged (Fig. 22).

11.5.2 Automatic Orientation

1. “Image to define correction from”: Select the bands (usually only the EW and NS bands) from which the correction will be defined.

2. “Ancillary file of one image”: Select the ancillary file of the image causing the undulations to be removed.

3. “GCPS file(if any)”: Select the GCPS file (if any) that was used to orthorectify the image. This is an optional parameters.

4. “DEM file(if any)”: Select the DEM file (if any) that was used to orthorectify the image. Attention, the DEM must be valid on the entire image area. This is an optional parameters.

5. “Stripes/undulations direction”: Select whether the artifacts to removed are oriented cross-track or along-track. For example, attitude undulations will cause artifacts in the cross-track direction, whereas a CCD artifact will cause along-track stripes.

6. “Image to apply the correction to (if different)”: If the corrections are meant to be applied to a file different than the one they are determined from, select it accordingly. It must be of the same size, with the same number of bands that the file used to determine the correction. A typical case is when a denoised and smoothed correlation file is used to determine the stripes correction, but the correction is applied to the raw correlation file. If this field is left empty, the correction will be applied to the file from which the correction is determined.

7. “Corrected File”: Select the filename to create if you want to save it to the disk. Otherwise, leave the field empty for in memory computation, but keep in mind the size of the image in regards to the available dynamic memory.

8. Click OK

9. After a short computing time, a transformed image with the undulations aligned either horizontally or vertically will be loaded in memory. Select the file and select the spatial subset that will be stacked to determine the correction. The same spatial subset will be stacked on each selected band.

10. Click OK

11. The output image will be the original file with the selected band corrected. The correction applied to the bands is appended as additional bands at the end of the file. The non selected bands remain unchanged.

11.6 Vector Field

This tool (“Tools → Vector Field”) displays a vector field based on displacement maps or ASCII files.

Loading Data: To load data in the Vector Field tool, do “File → Open”. Two kinds of data can be entered:

- “ENVI File”: When selected you will be prompted to enter the E/W band and N/S band successively of a displacement map to construct the vector field. The E/W and N/S band selected (and their subset) must be of the same size and must be georeferenced. A typical entry is a correlation file.
• “TXT File”: An ASCII file which must be of the form Easting Northing DEasting DNorthing. DEasting and DNorthing refer to the vector value in Easting and Northing directions at the location indicated by Easting and Northing. A typical entry is a GPS measurements file.

Note that additional data (from ENVI file or TXT file) can be added to the vector field display, but the ground footprint of the display will be determined by the first data entered.

**Vector Tool** Select “Processing → Tool Gui”. The vector field graphic options available are the following (Fig. 23):

- “Graph Title”: Enter the title of the vector field display.
- “Maximum vector value”: Enter the maximum value of the displayed vectors. Vectors of superior values won’t be displayed.
- “Ratio Arrow Length”: Ratio to control the length display of the vectors.
- “Unit”: Enter the unit name that is displayed on the vector field legend.
- “Vector Field Options”: The list displays all the data entered on the current display. Select the entry of interest to have access to the following options:
  - “Vector Field Name”: Select the name that will be displayed in the list.
  - “Average Window Size”: Option available only to ENVI data files. Determines the window (odd size) centered on the vector location to average the values in the file.
Figure 22: Destripping tool corrected image

- “Step”: Option available only to ENVI data files. Step in pixel between two displayed vectors. Performs the decimation of a displacement field if more than 1.
- “Line Thickness”: Ratio to determine the thickness of the displayed vectors.

Note: Saving the vector field as an ENVI Layer will not work in ENVI 4.0 due to an internal ENVI error.

11.7 Stacking Profiles

In the context of seismotectonics this tool ("Tools → Stacking") allows to stack profiles across the fault on the correlation file to retrieve the fault step. Prior to stacking profiles, a mapping of the fault is necessary:

1. Using the ENVI ROI tool with the polyline selection option (ROI_Type → Polyline), map precisely the fault. Once the fault is mapped, save the ROI using “File → Output ROIs to ASCII”.
2. Take note of the fault origin pixel coordinates (using the Cursor Location/Value tool), as it will be needed for the fault orientation.

11.7.1 Orient Fault

This step ("Tools → Stacking → Orient Fault") will rearrange the data contained in the fault profile file retrieved from the ROI tool. This process is necessary for two reasons. First reason, practical, is the necessity to reorder the fault points to physically follow the fault (the ENVI ROI tool save the points line-wise). The second reason is to define the origin of the fault, as it will dictates the fault orientation for measurements made parallel and normal to the fault. The parameters are the following:

1. “Fault Trace (ROI Ascii File)”: Select the file generated with the ROI tool when mapping the fault.
2. "Fault Origin": Enter the X and Y pixel coordinates of the first point of the fault (given by the "Cursor Location/Value" tool). If not selected, the first pixel found in the fault trace file will be considered the fault origin (which will be the top pixel (line-wise) of the fault trace).

3. "Oriented Fault File": Select the oriented fault profile file name to be created.

11.7.2 Stack

This tool ("Tools → Stacking → Stack") manages the stacking boxes and resulting profiles (Fig. 24). A stacking box is defined by its width and length which are expressed in pixels and must be odd. The box is centered on a pixel belonging to the fault. For each selected bands, profiles in the box length direction are retrieved and stacked. The resulting profile is displayed and the offset at the fault position can be measured using linear fit on the resulting profile.

Stacking Box Initialization: Boxes can be initialized using "Options → Initialize Profile", and/or can be added or deleted one by one using the "Add" and "Remove" buttons. There are two ways to initialize stacks:

- "Stack number": Select the number of stack to extract. Stacks will be evenly spread along the fault profile.
- "Stack spacing (pix)": Select the spacing in pixel between stacks. A spacing of 1 means that a stack will be extracted for every pixel of the fault profile (minus edge effect at the extremities of the fault profile). Use this initialization if you want a continuous fault slip measurement along the fault profile.

Size and center position of the selected box can be changed with "Stack Length (odd)" and "Stack Width (odd)" fields, and "Position on fault" buttons. The simple arrow button moves the box center to the next pixel on the fault whereas the double arrows button moves to the next 20ieth pixel on the fault.
Stacking Boxes Visualization: There are two visualization possible:

- “View → Stack Visualization” displays the spatial location and extent of the stack, i.e., the stack boxes. Open the ENVI ROI tool to display the stack boxes. Note that you can delete the stack boxes ROI without interfering with the stacking profile tool. Close all open ROIs before visualizing the stack boxes as open ROIs will be first deleted.

- “View → Offset Visualization” extracts the slip on the fault from all the stacks and plot them. Select the slip component you would like to display (band); you can also display the standard deviation of each estimated slip along the fault as well as the norm of the slip (norm of all displayed bands).

Profile projection: By default, profiles are in the file band projection, i.e. in the E/W and N/S projection for a regular correlation file. Profiles can also be projected in the fault parallel and fault normal directions, using “Options → Profiles Projection”. It is assumed for the Parallel-Normal projection to receive a two or more bands file with first and second bands representing the E/W and N/S displacements (a correlation file typically). For each stacked profile, the fit range can be customized on the left and right part of the profile as well as on the available bands. The range can be changed by moving the green rulers with the mouse or by entering range values in the appropriate fields.

Output: A stack project can be saved/restored using “File → Save Stack/Restore Stack”. Note that only the stacks size, positions, and fit ranges will be saved. You will be asked to enter the image and fault file when restoring. When done with adjusting the profiles, two options are available to export them:

- “File → Export → Fault Displacement” will save the fault offset measure location (geographic coordinates), its values (E/W-N/S or Parallel-Normal depending on the chosen projection), and the sigmas.

- “File → Export → Full Stack Information” will save in addition the details of each stacks (box size, profiles stacked, . . .).
The possibility of weighting the sigmas is offered before exporting the data. For example if the measures in
the correlation file are not totally independent, the sigmas must be weighted accordingly in order to correctly
reflects the sigma on the offset measures.

11.8 Manual Stacking Profiles

This function allows the user to extract stacked profile from an image (usually a correlation map). The
principle is similar to the one described in the previous section (Sec. 11.7), with a somewhat lighter approach
and a less “seismo-tectonic” feel. Basically the user doesn’t need to define a “fault trace”, and select directly
the profile of interest using the ENVI ROI tool. The steps to extract stack profiles are the following:

1. Open the image to extract measurement from.

![Figure 25: Manual stacking tool](image)

1. Open the image to extract measurement from.
2. Using the ROI tool and using the polyline selector (ROI_Type → Polyline), draw the profile of interest (Fig. 25, top-left panel). If you want to do several independant profiles you need to create a New Region for each of them.

3. Open the Manual stacking tool from COSI-Corr → Tools → Stacking Profiles → Manual stack (Fig. 25, bottom-right panel).
   
   - Select the image display ID of interest.
   - “Roi ID”: Select the ROI (i.e. profile) of interest.
   - “Type of profile”: 'Line' means that the profile will be a strict line computed from the first and last pixel of the ROI profile. The 'points' on that line do not necessarily fall on an integer pixel. A stacked profile is computed for every point (spaced by one pixel width) on that line. 'Curve' means the profile follows the ROI which is always on integer pixel. In order to find the direction perpendicular to the profile at any given point, a linear fit between neighboring pixels is computed (the neighborhood is same size as the "Stack size"). See Fig. 26 for an illustration.
   - “Stack size”: Select the box width in pixel. This size represents the number of pixel that will be average for each measurement along the profile.
   - “Image band”: Select the band(s) for which you would like to extract profile from.
   - “Display stack in ROI”: Check if you want a ROI representing the extent of the stacking box to be created (Fig. 25, top-right panel). You can manually delete these ROIs using the ROI tool afterward without affecting your stacked profiles.
   - “Plot Min/Max stack”: if checked, the minimum and maximum values for each value of the stack will be displayed on the profile window.
   - “Get profile!”: click to get the stacked profile (Fig. 25, bottom-left panel).

![Figure 26: 'Line' vs 'Curve' Stacking. On left panel two profiles using 'Line' specification. Right panel, the same two profiles using 'Curve' specification.](image-url)
11.9 Epipolar Projection

This function (Tools → Epipolar Projection) projects a displacement maps (a correlation file) which expresses the surface deformation in terms of East/West and North/South displacement components into a projection that expresses the displacement in Epipolar and Perpendicular-Epipolar components. This function is mostly useful when the topography residual is strong due to a poorly resolved DEM.

In theory, all displacements due to uncorrected topography will be projected in the epipolar direction, leaving the epipolar-perpendicular projection free of topographic residual. If the surface displacement is not entirely in the epipolar direction – which would be unlucky – the perpendicular-epipolar component will contains the surface deformation cleared of topographic artefact. Please note the following limitations:

- The epipolar and perpendicular-epipolar directions are not know exactly as the acquisition geometries are subject to error and approximation too. Consequently, the epipolar component will contain most of the topographic residual and some will be contained in the perpendicular-epipolar direction.

- The perpendicular-epipolar direction contains the *projection* of the surface deformation into that direction. The deformation measured in this component is not the absolute deformation, but just the projection of it into that direction.

- This approach only works if the surface deformation in the vertical direction is small compared to the horizontal deformation.

![Epipolar Projection](image)

Figure 27: Epipolar projection tool

In the GUI illustrated in Figure 27, enter the following information:
1. “Master Ancillary Data File”: Enter the ancillary file of the master image. The master image is the one used as the “pre-event” during the correlation. In case of frame camera system, enter the Exterior Orientation file of the master image.

2. “GCPS File (optional)”: Enter the GCPS file that was used (if any) to orthorectify the master image.

3. “DEM (optional)”: Enter the DEM that was used (if any) to orthorectify the master image.

4. “Slave Ancillary Data File”: Enter the ancillary file of the slave image. The slave image is the one used as the “post-event” during the correlation. In case of frame camera system, enter the Exterior Orientation file of the slave image.

5. “GCPS File (optional)”: Enter the GCPS file that was used (if any) to orthorectify the slave image.

6. “DEM (optional)”: Enter the DEM that was used (if any) to orthorectify the slave image. Usually the slave DEM is the same as the master DEM, but doesn’t have to.

7. “Correlation File”: Enter the correlation file that will be projected into the Epipolar and Perpendicular-Epipolar direction.

8. Select the output filename. The output will contain 5 bands: Epipolar component, Perpendicular-Epipolar component, SNR component (copy of the original SNR band), E/W direction of the Epipolar direction, N/S direction of the Epipolar direction.

12 Miscellaneous

- A queue manager is available in COSI-Corr to allow batch processing. An unlimited amount of tasks can be queued and will be processed on a first selected, first processed basis. When selecting data for a process to be queued, the data to be selected may not exist yet (for example when it is supposed to be computed in a task queued before). Depending on the type of data to be selected:
  - ENVI file: Click on “Cancel”. A regular file selector will be displayed. Enter the name at the correct path location of the file to be created. Note that in this situation, spatial and spectral subsetting are not possible. If no regular file selector is displayed, the file must then exist at the current time.
  - Other: Enter the name at the correct path location of the file to be created.

- Do not open more than one COSI-Corr window at a time (except for the queue manager window), as crash will occur otherwise.
In case of an ENVI blocking crash (due to more that one COSI-Corr window opened, bug, . . .), enter in the IDL command line: “retall” and press “enter”. It will most of the time unblock ENVI. If not, you may have to restart ENVI.
References


